How to Solve the 360 S6 Robot Vacuum Connection Issue

Some users have troubles in connecting the 360 S5 to the 360Smart app, so I decided to collect all the solutions our readers have found in the comments in our 360 S6 review.

As far as we know, there are a few different modifications of the 360 S6 robot vacuum on the market:

  • an international version. This version has an English manual in the box and speaks English.
  • a Chinese version: has a Chinese manual and Chinese voice.
  • some other local versions of the robot.

Some of the latest Chinese modifications are location locked. They were designed for the local China market, but for some reasons there are sellers on Aliexpress (and maybe other stores) sell it worldwide. Those devices can't be connected to the app outside of Сhina. However, there is a solution posted by Paul with a GPS Spoofing and proxy.

How to know if your device is locked? When connecting the device, you will get an error, something like this: "The product can be used in China only".

If your device is not locked or you have an international version

Before connecting the robot make sure that:

  1. Your Wi-Fi router works on the 2.4Ghz frequency band (not 5 GHz)
  2. Your Wi-Fi password must contain only Latin letters and numbers (if not — change it).
  3. Check if your Wi-Fi router uses WPA or WPA2 encryption (but not WEP or without encryption). You should log in to your router settings page (192.168.1.1 or 192.168.0.1) and change the encryption mode to WPA or WPA2.
  4. Go to the phone settings and check if the location permission for the 360Smart app is enabled.
  5. Turn off mobile data before connecting the robot.
  6. Move the robot and your phone closer to your Wi-Fi router.
  7. Reset the robot Wi-Fi settings by pressing and holding the "Power" and "Home" buttons simultaneously for a few seconds.
  8. Try to connect the robot. Sometimes app may ask you for manual connection, in this case, you should follow the instructions on the screen. If you followed all those steps, but your robot still won't connect:

If you have a locked Chinse version of the 360 S6

Paul posted this solution, and other users verified it:

  1. Follow all the steps described above for an international release.
  2. Uninstall the 360Smart app. Install the 3.1.0.0 version of the app Joshua Speer confirmed in the comments below that this method works with the latest version of the app.
  3. Install the Hola GPS Spoofer
  4. Install the Hola Free VPN Proxy
  5. Change the language of your phone to English
  6. Change the timezone of your phone to Shangai UPDATE: This step can be skipped.
  7. Run the Hola Free VPN Proxy and GPS Spoofer and set the location to Shangai and Proxy to China
  8. Run the 360Smart app from the Hola Proxy, and cross your fingers.

Follow the normal binding steps. If you have more than one Wi-Fi hotspot in your house, forget the others in your phone settings. Mobile data should be turned off.

When the binding of the device finished, you can use the app without the proxy and GPS Spoofer.

Please post your questions and solutions in the comments below.

Comments ()

  1. blueman2 07 december 2018, 15:13 # +1
    Can I use a 360Smart account with a US number for the China version binding process above? I was not sure since we are setting to China location when we do the binding. I cannot create a China account since I do not have a China phone number.
    1. Chris 07 december 2018, 15:46 # +1
      You need to do an email registration instead of phone number reg. The sellers of Aliexpress also advise the email registration method.
      1. blueman2 08 december 2018, 03:24 # +2
        Success!!! Aliexpress «Mainland China Only» version was finally able to bind and works perfectly. I tried using 360Smart Android App v3.1.0.0 as recommended above, but the old Android phone I was using had a low resolution screen which cut off the bottom of the app, so we could not select the «Purple Lights Flash» button. So we downloaded the latest 3.6.0.0 version of the Android App from Play Store, which did fit on the screen correctly. We started it from Hola VPN, selected GPS in China, set the robot in binding mode, pressed «Purple Lights Flash» button on the app, and it linked!!!

        I was then able to log in with my iPhone 7 using the latest version of the App (3.5 I think on the iPhone) and it works!

        Biggest issue I had was the robot is VERY finicky in broadcasting its WiFi for setup. I kept getting an error message to check my wifi. I had to turn the robot off and on several times, putting into link mode each time, in order to finally get it to broadcast its WiFi for linking. Once I got that working (you can check using your phone's wifi setting to see if the robot is sending out an SSID), it was a very simple process to bind it.

        So another confirmation that Ali Express versions with «Mainland China Only» issue can be linked just fine. We still have to live with the Chinese voice for the robot, but that is acceptable.

        Thanks for the help.

        Cheers
        1. sorin 08 december 2018, 10:04 # 0
          For me is not working, no matter the app version. It goes to 99% and it stays there, sometimes it throws network error. Same issue on 2 different phones. i think i will go for the refund.
          1. blueman2 08 december 2018, 11:24 # +2
            Try this. After you put the robot in linking mode (purple lights flashing) and before you use the 360Smart program to bind it, use your phone or some other device to do a wifi scan. See if the robot's SSID is there. I cannot recall what mine was, but it was obvious since it was the only other SSID my phone was seeing that I was not familiar with. And it was at the top of the list since the signal was so strong. I had LOTS of issues getting the robot to turn on it's wifi for the linking process. Not sure why, but I had to turn the robot off, on, then put in linking mode many times before it finally turned on wifi and I could see the SSID. Once you confirm the SSID is visible on your phone, THEN try to do the binding with the 3.6.0.0 app with GPS and VPN spoofs running.
    2. Hans 07 december 2018, 17:11 # +1
      I also bought a Chinese version on Alieexpress and I’m struggling with the same problem: connection failed. I tried the steps described above but I can’t install the new version of the app. Can you give me more instructions on this? Does this work on iPhones as well?
      1. Michael Fisher 08 december 2018, 09:34 # 0
        Hi Hans,
        In the comment above, blueman2 has been able to connect the robot with the 3.6.0.0 version of the app (which is already available for Android) and the described method. I don't know if there is an update for iOS devices, if not — it should be in the Apple Store in the coming days. I have no proofs this method works with an Apple phone. However, you can ask your friends for an Android device to connect your robot. When it is connected, you can use your iOS device with the robot, as well as blueman2 did.
        If you want to try this method on an iPhone, you need to find in the App Store and install a GPS spoofer and VPN proxy.
        1. guido 10 december 2018, 11:26 # 0
          Do you maybe know which version of android is necessary to solve this issue?
          I have android version 6.0 and can not connect/bind to a robot… and I have tried everything here mentioned with all app360 versions
          1. Michael Fisher 11 december 2018, 08:00 # 0
            Hi,
            Looks like the latest version of the app for Android 6 is 3.5.0.0, the newest version 3.6.0.0 released last week only for Android Oreo and Pie as I know. I don't know if there are some fixes related to the connection problem, but it can be a reason if you tried everything and it doesn't work. You can try to install an older version (3.1.0), there were a few users who connected the robot with the described method and this version of the app.
          2. guido 10 december 2018, 11:56 # 0
            … and what could be robot's wifi password if I would like to bind it manually?
            1. Natalie Red 11 december 2018, 01:57 # 0
              It must be your wifi router password.
              1. guido 11 december 2018, 06:08 # 0
                router password is not the right one, tryin to understand why should it be?
        2. Nejc 08 december 2018, 08:21 # +1
          Hello guys. New app is released 3.6.0.0 and I downloaded it. Did anybody notice any problems with this version ( cleaning,finding dock..)? Thx. Bw
          1. guido 08 december 2018, 09:09 # 0
            I also got a Chinese version and unfortunately none of the above solutions works for me… does anybody succeed to retuen it back and to get a refund?
            p.s. I bought it at aliexpress, seller was Perfection Technology
            1. blueman2 08 december 2018, 11:21 # +2
              Mine was also Ali Express from Perfection Technology. It was ordered on Nov 23 and arrived Dec 6. I did sent a note asking for help but have not heard back yet. From another post I saw, Perfection Technology was willing to do a refund (YMMV). BTW, while I got it to work just fine with the App on iPhone (after binding it with an Android device), it is still giving Chinese language voice prompts. I see no way to change that to English at this point. But that is really just a minor annoyance. The app itself is of course in English so I can do everything I want.
              1. D 15 december 2018, 14:12 # +1
                Sorry cannot create a new comment, but only reply. I also have the chinese version from Ali. I cannot see the 360AI-CleanRobot wifi signal on my phone. From my computer and running a wifi scan, I can see it is on channel 13. Is there a way I can get my phone to see the robot's wifi signal (I am in North America so only ch 1-11 is visible from the phone I believe). Or alternatively, is there a way I can use my computer to run the apk since my computer can connect to the robot?
                1. blueman2 15 december 2018, 17:12 # +1
                  D,

                  You may have just figured out the issues we have been having with connecting to the wifi for the Chinese version! Yes, Europe and Japan (and I assume China) use channels 1-13 for wifi, whereas in the US we only use 1-11. So my guess is that the robot comes up with various channels when it boots, and if it chooses 12 or 13, that creates the issue for us trying to connect. That would explain why I had to reboot the robot numerous times before it finally came up with a channel that was in the US range. This is just conjecture, but seems to make sense. Since 12 and 13 are unused in the US, and wifi hot spots will tend to try to use a channel that is open, that might explain why so often it is going with those channels. But if you keep rebooting, it will eventually use a channel you can see. See if several reboots eventually will work to get a 1-11 channel.
            2. Joshua Speer 08 december 2018, 20:48 # 0
              This also does not work for me. I've tried all the suggestions on the original comment thread this information came from as well as these. I'm thinking some received a different firmware revision on their robot. Mine is also from Perfection Technology. Even knowing the issue with these they continue to list them for sale outside of China. I'd think they'd pull them if they were serious about it. The company just referred me to try what is instructed here but I've already done that. I've tried 2 different phones and a tablet as well as verified that both the gps and vpn were in fact reflecting Shanghai China along with the time zone changes. No luck. My wife and I would like to keep it for the basement but not at the cost it is with such limited function not utilizing the app.
              1. blueman2 08 december 2018, 23:06 # 0
                Joshua, what error message are you getting when you try to bind the robot? Can you do a screen capture of your phone and post it here?
                1. Joshua Speer 13 december 2018, 11:52 # +2
                  UPDATE: I was getting a connection error. It turns out it was the VPN suggested. It just doesn't connect for me on any device. I did figure it out. I had an extra router that I could plug the VPN details into for PureVPN. They have a couple Chinese locations. I had to pay for their service but I've been meaning to get a a VPN provider anyway. I then connected that between my primary switch and POE switch with WiFi AP's. Then waited a minute for it to connect to China and was able to register the damn thing. Removed the VPN router and reconnected the regular way. While dealing with this I purchased a white international one on Amazon from the 360 company. I'm hoping that some day someone will release a method to sideload the ROM so I can get the Chinese one to use the international firmware. Also I did not need to adjust my timezone just spoof the GPS. The router was compatible with and using ddwrt firmware. Also I used the current app version. There was no need to get the old one.
                  1. Michael Fisher 13 december 2018, 12:55 # +2
                    Hi Joshua,
                    Thanks for your update! I've fixed the guide.
              2. Linas 12 december 2018, 10:21 # +1
                Hello,

                for me not working Hola Free VPN Proxy China server, so can't use that app. Tried with Hong Kong server, got China Mainland error. Also tried private China proxy, but the problem with this is that when Smart 360 app connecting to robot WiFi network the phone is disconnecting from my home WiFi network and also the phone is turning off VPN switch (the key icon), so when the Smart 360 app reconnecting to my home network back my IP address is not anymore under China proxy. So I think I need the phone app which can proxyfie only the Smart 360 app (like the Hola VPN app doing) not the whole phone, so the proxy is not tied to WiFi network, but just the chosen app, so when Smart 360 app switching between the WiFi networks the proxy is not turning off/disabling. Also tried other free VPN apps and they also disconnecting when WiFi network is switched. Premium paid VPN didn't tried, because I don't want to pay if I don't know if theirs mobile apps will succeed to bind the Smart 360 app to robot.

                Also wrote the complain to the Smart 360 app support and got response from them that I need to contact their official after-sales by phone +86 400 6822360, but I don't think that they can provide me the international version of firmware.

                Only two ways for now I see, is to return back the robot to Aliexpress seller (he agree to accept the return for full refund plus shipping fee) and buy new one with International version firmware. Or to wait for maybe that manufacturer will make the fix for Chinese versions to unlock region locks, provide international firmware or that maybe someone will make modified 360 Smart app where will be disabled the region check like it was done with app for Roborock s5 in one Russian forum.
                1. blueman2 12 december 2018, 16:06 # +1
                  Linas,

                  When you say Hola VPN China server is not working for you, is the Hola app working, but just not that one server? In that case, it might just have been down for a bit. It was down when I first played with the app, but was up about 6 hours later when I did the binding. So maybe try again later??
                2. blueman2 15 december 2018, 17:19 # +1
                  I am adding a new post so that the issue is not lost in the above thread. D did some good detective work and found out that his Chinese version of the robot was using Channel 13 for WiFi. Since the US only uses channels 1-11, this might explain why some are having issues connecting. I believe each time you start a new linking sessions (purple light flashing) it will choose an an open WiFi channel to use for broadcasting itself. Since 12 and 13 are not used in the US, it probably sees those as open and uses one of those most of the time. But eventually, if you try rebooting and start a new linking session, it will use a channel in 1-11 and that will allow you to bind.

                  Just conjecture, but might be worth more looking in to.
                  1. D 15 december 2018, 20:27 # 0
                    Hi, is rebooting simply making sure the robot is not in the charger and press the power button? Then power up (blinking blue), press both buttons to purple? I've restarted about 10 times and it's still on channel 13.

                    An alternative, I have a borrowed iphone and I can see channel 13. However, I now need a good VPN proxy and GPS Spoofer for ios. Any suggestions? Otherwise, I'll keep rebooting the robot for my android
                  2. ManuUI 16 december 2018, 16:03 # +2
                    Hi everyone. After half a day of frustration of not being able to connect my 360 to my app I found a solution in a German robo forum.

                    There is a beta version of the app (3.5.0.8_beta), which is not available in Google Play, but offered by 360 directly. It solved the issue for me as well as other users in the German forum.

                    Here's the link: www.mediafire.com/file/8x0t0sjc0i3o1uq/release_360SmartHome_V3.5.0.8_V190_2018-11-21_10_43_37_35fc3ebe63ee7511bfdcbb91ba066b9144983415.apk/file

                    Not sure when this will be implemented in a new official release, but that did it for me.

                    Cheers
                    1. JB007 16 december 2018, 17:02 # 0
                      Hello Manu,

                      You have chinese version or robot or International one?
                      I tried with this apk too (without vpn), but still receiving «mainland China» message.
                      1. ManuUI 16 december 2018, 17:40 # +1
                        Hi, I've got the international version. This fix is only for the bug in the App (connection failed message). Not for getting the chinese version to run outside of China.
                      2. Michael Fisher 17 december 2018, 02:24 # 0
                        Hi,
                        great! You can find the link to this beta app in this guide too, maybe you just missed it:)
                      3. D 16 december 2018, 16:10 # +2
                        Update! Got it working. For iphone apps I used Fake GPS by Riddhi Rakeshbhai Patel and for VPN I used Transocks. Transocks is in Chinese and I'm not sure how it works, but I pressed the Connect button and then tried to bind the robot and it worked. Transocks has some ads too and when I searched for «What is my IP?» it showed I was still in North America despite being connected to the VPN. So not sure why it worked, but it worked nonethless. I tried other VPN proxys with Fake GPS but only Transocks seemed to work plus it's free.
                        1. JB007 16 december 2018, 17:06 # +2
                          Man you are the King ;)

                          Transocks VPN for Android also worked, finally have my robot connected ;)

                          I have black chinese version of s6 360 robot, and as D suggested, used transocks (from play store) VPN and just hit connect, and after 10 second I got my robot binded — connected to app. Updated firmware of robot and app to 3.6.0.0 and everything works perfectly.
                          1. Michael Fisher 17 december 2018, 02:34 # 0
                            Hi,
                            thanks, now we have a solution for iOS users, I'll add this to the guide.
                            1. JB007 17 december 2018, 02:53 # +1
                              I think transocks VPN is also solution for Android… As I did it with transocks and got my robot connected to app. I am just not sure does we need hola gps spoofer or not… I had it installed and set to Shanghai anyway.
                              1. Michael Fisher 17 december 2018, 03:07 # 0
                                A lot of Android users have troubles with the Hola Free VPN Proxy, so maybe the Transocks VPN works better. So you have connected the robot without the GPS spoofer?
                          2. JB007 17 december 2018, 03:18 # +1
                            Michael, i cant confirm it, as I had it installed on my phone, but I am not sure did I used it in time of «connecting» robot and app, or I didnt. I just cant remember.

                            But with transocks got my robot connected in 10 seconds and everything works perfectly.
                            1. Goor 19 december 2018, 16:26 # +2
                              Hi everyone,

                              I might be onto something — not sure if it was a fluke, but it worked — so after spending the past 2 weeks in the forum I owe you that much to share it and hope it will help others.

                              Yup, 2 weeks… Tried over and over and over, tweaking some attempts and changing some steps in the guide here and there, but after an hour I would give up, bad mouth the annoying chinese girl in the voice prompts and try again the following day. Today it suddenly gave me successful binding message on the screen when I least expected it, and you'll understand why in a sec, and I will try to point out all the tech info for the record:

                              App: Eventually what worked for me was the 3.1.0.0 version apk from the link above, but I did try 3.6.0.0 to begin with. I saw some users had an issue signing up with SMS. I personally haven't (and it's an EU mobile number, not US and definitely not Chinese), but just so you know it is possible to sign up with an email on the app version 3.1.0.0 — I did that although the SMS sign up went well just in case the system will somehow realize I'm not in China if only by the mobile number.
                              Either way, I want to emphasize that if it did in fact work for someone with version 3.6.0.0 it might have to do with the OS — I could not pass the 13% with that version no matter what I tried changing. It is evident that this version recognizes the location even behind a double VPN, let alone one, regardless of an IP and GPS location in China, your system's clock or language — so I would suggest not to waste your time on trying with the updated version, but then again maybe it was just me. I installed 3.1.0.0, and when it finished clicked «done» and not «open» — then went first thing to Google Play to disable auto updates (because they managed in few cases to be faster than me and auto-update before I went through the entire process).

                              System: Android Oreo 8.0.0 (yeah, not even 8.1. Apparently LG has more burning stuff to do. But, don't be alarmed if you're not on Pie, that's not it). Needed or not, I set the time manually to China Standard (GMT+7) to be on the safe side, and the language is anyway set to English.

                              Location: Changed the setting from High Accuracy to GPS only. Again, dunno if it's vital since you are going through a VPN, but what have you got to lose from limiting the system to have only one option to determine your location.

                              Internet connection: Now, I know my ISP router is not the smartest piece of technology around, so in attempt to get the best possible signal even through a VPN (that one was very touch n go. At times I could not even log in to the app and received an error that the network has bad connection, which a speed test confirmed) I disabled temporarily the 5 network and left only the 2.4; Also, since I normally use custom DNS I've disabled that (if you don't know what it is, you're not using it so don't worry). On the phone I've turned off the mobile data, reset network settings (it's in the network menu), and reconnected to the wifi, which was now broadcasting only on the 2.4 network anyway.

                              VPN: well, Hola. Never been a huge fan, but then again you can't complain about a free service. The thing is, their work model to give it to you free is making you a peer so Hola is using some of your bandwidth for other users who want to connect to a server near you. Like I didn't have enough to deal with here, I need to rely on other Hola users and hope I get lucky. Of course, I didn't. Countless attempts all failed and in cases I did manage to log in to the 360 app, it either got me to 15-20% and gave an error or the more enjoyable error at 99%… I tried several other (paid) major VPN providers, both on the phone level and on the router level, but it seems that indeed the way is with Hola since that is directly on the app level. The solution: forget Hola Free and sign up for the 3 day trial of Hola Plus. You won't be charged as long as you remember to cancel the subscription during the trial period and you can guarantee having a connection way more reliable than the free peer-to-peer one.

                              With everything set, I reset the robot (pin through the tiny hole behind the rubber piece covering the usb port, when the dust bin is ejected) and restarted it; placed myself in the Hola GPS app on some unnamed road in the middle of Beijing; and opened the 360 app via the Hola Plus. Signed in, and started the binding process for probably the 360th time.
                              Now… I'm not totally sure what happened next and how this would have ended if the following didn't occur, so my best advice would be to follow it through with the binding as usual and if it still doesn't work try recreating this scenario:
                              Binding ongoing and when reaching the 15% mark the annoying girl's voice appears and talking to me in Chinese again which I already know means it failed although the app would keep going to 99% and then give me an error, I eject the dust bin and got the pin in hand ready to reset the robot again when Spike, my cat, decides to shove his head to see what's going on. No worries, you won't need a cat for this — but I'm telling this because during the split second that I looked up from the phone screen to make sure I'm not poking him in the eye with the pin, the «binding successful» screen appeared. Sadly, until my astonished brain registered what just happened my hand was quicker and reset the robot. That was the point when I didn't know whether I should bang my head or the robot against the wall… finally it bound and I reset it?! But lo and behold… the app was searching for the robot, and as soon as the latter rebooted itself it was still there. The first few seconds were lagging, but once I updated the firmware through the app and the robot automatically rebooted again, everything was fine. I then reversed all the changes made in the phone and router, disconnected from the VPN and updated the app itself. I should note that although you can update from within the app, I opted for not playing with fire now that I am no longer pretending to be in the middle of some road in Beijing and updated the app through Google Play. It updated to 3.5.0.0 which is the latest offered through Google and not 3.6.0.0 — but honestly? I couldn't care less. Everything was working fine, the app is completely in English, and the only thing I can't get rid of is the annoying Chinese girl (though I did set her volume to minimum). Did a few runs with the robot since, turned phone on and off, rebooted the router even — but the robot is there, bound. Nailed you, mofo.

                              So to recap: try following all those settings and steps described and then bind (from a fresh start, i.e clean installation of the app, and do try with 3.1.0.0 first, before you update from within the app to 3.6.0.0), but it still won't work:
                              — start binding
                              — at the voice prompt around 15% eject dustbin and reset robot with a pin
                              — cross fingers and restart robot
                              You can borrow Spike for good luck, but I should warn you he's trying to hunt the side brushes.

                              Hope it helps! Good luck :)
                              1. Goor 19 december 2018, 16:32 # +1
                                Meh. Only now I see the Transocks option suggested above. i did try a bunch of Chinese VPN providers but missed this one… So maybe try that first before you sign up for a Hola Plus trial, just in case you'll be so excited that you managed to bind it and forget to cancel the subscription…

                                #sigh #wishIknew
                              2. Mantas 07 january 2019, 08:51 # +1
                                Hi
                                maybe someone will be able to help me, i also bought a chinese version of the s6 vacuum cleaner.
                                I tried everything. three different phones. two different wifi networks. VPN five applications. three gps programs. from oldest to latest app pump. and my best result was loading 98% of the program.
                                Anything listed in these requirements is fine. I no longer know what to do.
                                1. Michael Fisher 09 january 2019, 04:17 # 0
                                  Hi,
                                  sorry to hear that. Everything we know at this moment you can find here, unfortunately, it's hard to say why it doesn't work in your case. You can also check comments in our review, some guys have the same problem — binding goes up to 99%, but I don't know if they solved their problem.
                                2. Marco 18 january 2019, 04:36 # +1
                                  I have a Chinese version of S6 360. I was able to activate it thanks the instruction that you wrote in this forum. Many thanks.
                                  Now, I received a notification of a new version of firmware and new version of Android app.
                                  Has anyone update the firmware and the app to the latest version? Everything still working?

                                  You must be logged in to post a comment. Please sign in or sign up.



                                   

                                  Find the Best Robot Vacuum