How To Solve Wi-Fi Connection Issue With the Roborock S4 / S5 / S6

A lot of users who bought the Roborock S5 (also known as the Roborock S55, S50, S551, and S501) have some troubles with connecting the robot to Wi-Fi. Here is a step-by-step tutorial on how to solve the connection issue with the Roborock S5 (it is also suitable for the newest Roborock S4 and S6 models. I’ve checked this method with an Android phone, for iOS devices, the steps should be very similar.

The S4 and S6 models can be paired via the Mi Home (Android, iOS) and Roborock app (Android, iOS) when the S5 supports only the Mi Home app.

Step 1

Go to the Mi Home app settings and change the region to your local region, do not select China mainland.

Step 2

Go to the phone settings and make sure the location permission for the app is enabled.

Step 3

If your Wi-Fi password contains special characters like questions mark, colon, change the password without them to have a try.

Step 4

If the app says it could not connect to the public Wi-Fi, it is probably because your Wi-Fi encryption mode is WEP. You should log in to your router settings page (192.168.1.1 or 192.168.0.1) and change the encryption mode to WPA or WPA2.

Step 5

You could try to reset Wi-Fi by holding the "recharge" button and the "spot cleaning" button for 5 seconds until you hear a voice prompt.

I would also recommend to download and read the official step-by-step guide on how to connect the Roborock S5 with your smartphone:

* Please notice the vacuum could not connect to 5GHz Wi-Fi.

roborock S5 connection issue

Notice: Please keep your eye on Wi-Fi indicator light under the cover of the device. It will flash with higher frequency than normal status when it is trying to connect wifi and become solid when it is connected. Sometimes app may show error after connecting steps finish, but the Wi-Fi indicator light becomes solid and the device is actually connected to Wi-Fi successfully. In this situation, please close the app and run it again to see if the robot is on the list of app.

If you want to use the Roborock with Alexa, please check this manual.

If you tried everything and it still doesn't work, I would recommend you to contact Roborock official customer support:

I hope it will help you. If you have any questions or tips, please leave a comment below. You can also ask any questions related to Roborock product in the unofficial Roborock community on Reddit.

3
924
42
+3

Comments ()

  1. SigTill
    #      +1
    Even better — use the Flolevac to control the Xiaomi and download the newest firmware. Works like a charm!. play.google.com/store/apps/details?id=de.flole.xiaomi&hl=en
    reply   
    1. Crenguta Eftimescu
      #      0
      Apple store, can t find
      reply   
    2. mobilus
      #      0
      the same problem. who can fix it??
      reply   
      1. Robocock
        #      0
        Just spent 3 hours attempting all possible fixes and nothing!
        I believe the region switch hack is a Chinese prank and this article is a troll

        Using iOS Mi Home and Roborock S50

        reply   
        1. Robocock
          (edited})
          #      +3
          Fixed it!!! Again this is for Roborock S501-01, BC Model

          I got the following response from customer service as I attempted to return the unit: (Note: I am fixing some of the grammar for your benefit)

          1.Please go to app's setting to change region to your local region, do not select China mainland.
          (in my case I changed to US (Recommended), not the US (Singapore))
          2.If your phone is android, please go to phone's setting to enable the location permission.
          3. If your wifi password contains special characters like questions mark, colon, please change password without them to have a try.
          (this is what fixed it for me)
          4.If it says it could not connect public wifi, it is probably because your wifi's encryption mode is WEP. Please log in your router's page to change the encryption mode to WPA or WPA2.
          5.You could try to reset wifi by holding recharge button and spot cleaning button for 5 seconds until you hear voice reset wifi.
          6. Please notice the vacuum could not connect 5G HZ wifi.

          Notice: Please keep your eye on wifi indicator light under the cover of device. It will flash with higher frequency than normal status when it is trying to connect wifi and become solid when it is connected. Sometimes app may show error after connecting steps finish, but the wifi indicator light becomes solid and device is actually connected to wifi successfully. In this situation, please close the app and run it again to see if device is on the list of app.
          reply   
          1. Michael
            #      0
            Hi,
            thank you so much for your solution! I've updated the article. Hope it will help other users as well.
            reply   
            1. essess
              #      0
              Regarding «Please notice the vacuum could not connect 5G HZ wifi» does that mean that Mesh Wifi networks not separating the 2.4 and 5 GHz, like Google Wifi and TP-Link Deco M9 Plus, cannot connect to Roborock?
              reply   
              1. Emanuele
                #      0
                I have a Deco E4, but I don't find any solution to connect. Have you found one?
                reply   
            2. Richie
              #      0
              My roborock S50 2nd generation keeps going offline everytime after it finishes charging.
              Have to reset the wifi each time to get it connected to the app again. Very annoying.
              I have it for 2 months now
              reply   
              1. Michael Fisher
                #      0
                Hi,
                Did you try to contact Roborock official support? Hope they have some advice on how to solve this problem.
                reply   
                1. Leo
                  #      0
                  The same f… problem :(
                  reply   
                  1. lupoalba
                    #      0
                    also my roborock going offline everytime after it finishes charging…

                    reply   
                  2. Vas
                    #      0
                    Hi
                    I am on 5ghz wifi with iPhone 8. And I changed region to US and I reset few times still no luck connecting. I need help and I am not IT savvy. Can anyone pls guide me?
                    reply   
                    1. Michael Fisher
                      #      0
                      Hi,
                      you should switch your router to the 2.4Ghz frequency band since the Roborock doesn't work on 5Ghz.
                      reply   
                      1. Marco
                        #      +1
                        Yep, that worked!
                        Thanks!
                        reply   
                        1. helen
                          #      0
                          I'm sharing my hotspot from my phone, and its not connecting. I don't have a router at home we use my iPhone 11 for that. Any idea how to connect it keeps asking me to bring device closer, I put it on top and still nothing
                          reply   
                          1. Michael Fisher
                            #      0
                            Sorry, I've never tried to pair it through an iPhone hotspot, so hard to say why it doesn't work.
                            reply   
                          2. Stefanie Powers
                            #      0
                            How ????
                            reply   
                        2. Volodymyr Shulga
                          #      +1
                          Had the same issue. Option 4 helped me, I had to change Wi-Fi encryption mode from WEP to WPA2 for my Wi-Fi router. For this I also had to find IP address of my router, for Mac it could be done in following way — osxdaily.com/2011/10/05/find-router-ip-address-mac/.
                          By the way — I had not had any warning about not secured connection, just was not able to connect my iPhone 8 to vacuum.
                          reply   
                          1. Ju Yeong
                            #      0
                            When i dock my roborock, it reads docked successfully and is charging. But after more than half a day and the battery level still remained at the initial level. How can it be charging when the battery level remained the same? Pl somebody advise me.
                            reply   
                            1. Janice Massey
                              (edited})
                              #      +1
                              I found below comment from Reddit. And it works for me. Hope that helps you all.

                              «Hi, I had the same issue, I figured out the fix.
                              This is the problem.
                              You need to go into your router settings and enable the 'Guest 2.4GHz' Wifi connection.
                              Connect your phone/tablet to this guest signal. Then follow the instructions as per mi home app.
                              Once the roborock is connected you are then able to change your phone/ipad/tablet connection back to your preferred Wifi signal signal.
                              Now your roborock will be using the guest signal.»
                              reply   
                              1. Me
                                #      +1
                                I changed the router and could not connect to the vacuum via my phone using the Xiaomi Home app.
                                This worked for me.
                                1. Delete the Xiaomi Home App
                                2. Reinstall Xiaomi Home App
                                3. Click «Add Device» on top right hand side
                                4. Hold the Spot and Home button on the vacuum for a few seconds, this will trigger the vacuum wifi reset.
                                5. The Xiaomi app detects the device as a new device and kick off a new installation, which lets me put in the new router settings/password.
                                reply   
                                1. Bartosz Winiarski
                                  (edited})
                                  #      +1
                                  I had the same problem with the Roborock S6. It was caused by a special character in the SSID of the wireless network.
                                  reply   
                                  1. Simon
                                    #      +1
                                    For me it helped updating firmware of my router.
                                    reply   
                                    1. JK
                                      #      +2
                                      While troubleshooting, I tried all of the above suggestions with no luck… until I replaced the default router that Spectrum provides. Going through the listed steps using a Linksys EA6350 router worked like a charm.
                                      reply   
                                      1. Beanzalo
                                        #      0
                                        I think it totally sucks, that for every expensive product we buy, we have to depend on forums to resolve problems the manufacturer is responsible for, and they get off the hook. I cant connect and my solution is going to be a return.
                                        reply   
                                        1. Dana
                                          #      +1
                                          Hey guys so I connected my iPhone and my iPad to the roborock6 by taking the suggestion of changing my WiFi password to something with only letters and numbers (no special characters),but then it still said no WiFi found, so then i manually typed my WiFi name and the password then boom!!! Connected! It finally worked! Hope that helps, (side note- i have an old iPhone 6)
                                          reply   
                                        2. NK
                                          #      +1
                                          I solved the issue by following below steps:

                                          Press Dock button (first button next to the start / stop button), hold that button for a couple of seconds and then use a pin or something to press the reset button right next to the wifi light. Hold both of them until you hear music.

                                          Once it restarts, open the app and it will pick up roborock this time.

                                          It does really suck to spend so many hours to figure this damn thing out. But hey, it works now!!!
                                          reply   
                                          1. David
                                            (edited})
                                            #      +1
                                            Hey NK, I am still having the issue with the app just got the s5 did all the steps above nothing is working for me. I was using the app on ios. I don't see the roborock pop up no matter what I do. I don't see a connect to wifi option and nothing with search for nearby devices either. Edit:Paired it with my dad's android and setup with my phone after
                                            reply   
                                            1. Jolanta Gaižutienė
                                              #      0
                                              So with Android works??
                                              reply   
                                              1. Stanimir
                                                #      0
                                                I just tried this method and it worked for me — MIUI 11 / Android 10. Prior doing so, I also tried:

                                                1. Resetting only the Wi-Fi settings (hold re-charge / dock and zone clean buttons)
                                                2. Re-installing the android app
                                                3. Using a different 2.4Ghz network (used my guest network), although my router already had 2.4Ghz network enabled.
                                                4. Tried changing the region to Chinese Mainland and vice-versa.

                                                Hope this helps!
                                                reply   
                                          2. Dmitriy
                                            #      +1
                                            As somebody wrote here. Main problem could be in wifi router.
                                            Second problem, router has to have internet access otherwise robot will not connect to network. I don't know why it has internet access if you want to control it from the same network.
                                            Name of the network has to have the simplest possible name.
                                            Password also should contain only characters and numbers without symbols.
                                            I was not able to connect to my router provided by operator. It contain 2.4b/g/n/ac standards and 5GHz(which is not supported by robot)
                                            May be robot could not automatically select roper wifi standard or router was not properly configured.
                                            Only get success connecting to Travelmate titan wifi router. Had to share internet from laptop. Set static lan ip between laptop and travelmate. Simple ssid name and password.After all was connection, but took long time until it get solid connection.
                                            You can check standards in Travelmate and set your home router to this parameters, may be this will help you.

                                            And again in robot no 5GHz, it do not support it.

                                            reply   
                                            1. Søren Nielsen
                                              #      +1
                                              I have yet to be able to 'initialize' my S5 on any of my apple products.
                                              I then installed Xiomi Home app for android via Bluestacks on my PC and THAT worked… is the iphone/ipad app bugged?
                                              reply   
                                              1. Passerby
                                                #      +1
                                                Just wanted to add another solution that may help others. I have S5, and it was working fine until recently. It disconnected from WiFi and Mi Home app. I'm guessing maybe an update messed it up somehow because it was working fine for a year without a problem. After that, I tried to reconnect it, but nothing worked, including suggested solutions on this page. I even went as far as factory resetting not only my S5 but also my router (since someone mentioned that their issue had to do with their router). After going through all that, the solution was very simple but counter-intuitive. Their support rep told me to change the location to Singapore and try it (I'm in USA). Well, what do you know? It fixed it. It's working now. So, you may want to try this if you are facing the same issue.
                                                reply   
                                                1. Michael Fisher
                                                  #      0
                                                  Thanks for your solution. This advice should help for those who had problems with their devices during December 25-26, since there were some issues with the US server (not sure if they are solved already). So when you changing the region, the app connects to another server.
                                                  reply   
                                                2. Bill
                                                  #      0
                                                  @ Passerby (and Michael),
                                                  Just tried (feb 2020) the switch to Singapore (local to Denmark) and that worked!!!
                                                  Also, I don't know if Roborock is now sending an updated interface to other countries, but I got the version 3.2.7_002008 update, which is supposed to include an interface that allows S5 users to now independantly choose rooms to vacuum. I hope that works, because that was something I sorely wanted. Thanks for the message Passerby. Otherwise, I agree in wondering why I have to use days searching for a blog that addresses these problems.
                                                  Happy vacuuming everybody!
                                                  bill
                                                  reply   
                                                  1. Andrea42782
                                                    #      0
                                                    Ok so I had the same issue and I just fixed it. You have to attach an Ethernet cord to your router with a laptop or computer and google the IP address for your router. Mine is a TP link so the IP is 192.168.0.1
                                                    I put this in the search bar in my browser and it brought me to the log in page for the router. The log in is admin and pass is admin. I turned off the 5g under the wireless category and reset the router by turning it off and back on...then followed the steps in the app to connect. Make sure after you get the wifi to blink that you tap on the circle next to where it says you completed the action. (It doesn’t even look like something you would click on but you can’t click next until you touch it) Then you can click next and go through the steps of connecting it through the wifi. Mine is connected and updating firmware now! Success!!!
                                                    reply   
                                                    1. Søren pedersen
                                                      #      +1
                                                      I don't know if this is going to help but it worked for me. I changed the wifi on my phone (android) to 2.4 ghz and then the app is working. If you are connected to 5 ghz on the device where you are using the app, it is not going to work. Then after you are connected to the app, you can switch back to 5 ghz on your device. It is all the products from China with wifi, that has this problem and it is a weird way of doing things
                                                      reply   
                                                      1. cBeam
                                                        (edited})
                                                        #      0
                                                        So guys, are you serious, to make a vacuum work one needs to jump through hoops, make your wifi connection less secure by prohibiting special characters, and turning off the firewall as recommended in Roborock's troubleshooting guide: «It is recommended that you do not add a firewall to your router».

                                                        I say: It is recommended not to buy this thing. I returned the Roborock S6 after wasting hours trying to get it work. No more.
                                                        reply   
                                                        1. quatrio
                                                          #      0
                                                          Change the WiFi Password

                                                          I had many failed attempts to connect Roborock S6 Pure app to WiFi.
                                                          As soon as I changed my WiFi Password by removing any special characters (*&$#-+=) then it worked.
                                                          Changing security method from WEP or anything Did Not Work.
                                                          So just change your WiFi password.
                                                          Good luck
                                                          reply   
                                                          1. Kobi
                                                            #      0
                                                            Thank you so much! <3
                                                            After alot of efforts we changed the wi fi password (which was a phone number) and it work!
                                                            reply   
                                                          2. quatrio
                                                            #      0
                                                            You’re welcome, I’m pleased it worked for you.
                                                            Enjoy your Roborock. I think the app and the robot work great.
                                                            Best regards.
                                                            reply   


                                                             

                                                            Share via: