How To Solve Wi-Fi Connection Issue With the Roborock S5

A lot of users who bought the Roborock S5 (also known as the Roborock S55, S50, S551, and S501) have some issues with connecting the robot to Wi-Fi. Here is a step-by-step tutorial on how to solve the connection issue with the Roborock S5.

Step 1

Go to the app settings and change the region to your local region, do not select China mainland (in my case I changed to the US (Recommended).

Step 2

If you are using an android phone, go to the phone settings and enable the location permission.

Step 3

If your Wi-Fi password contains special characters like questions mark, colon, change the password without them to have a try.

Step 4

If the app says it could not connect to the public Wi-Fi, it is probably because your Wi-Fi encryption mode is WEP. You should log in to your router settings page (192.168.1.1 or 192.168.0.1) and change the encryption mode to WPA or WPA2.

Step 5

You could try to reset Wi-Fi by holding the "recharge" button and the "spot cleaning" button for 5 seconds until you hear a voice prompt.

I would also recommend to download and read the official step-by-step guide on how to connect the Roborock S5 with your smartphone:

* Please notice the vacuum could not connect to 5GHz Wi-Fi.

roborock S5 connection issue

Notice: Please keep your eye on Wi-Fi indicator light under the cover of the device. It will flash with higher frequency than normal status when it is trying to connect wifi and become solid when it is connected. Sometimes app may show error after connecting steps finish, but the Wi-Fi indicator light becomes solid and the device is actually connected to Wi-Fi successfully. In this situation, please close the app and run it again to see if the robot is on the list of app.

If you want to use the Roborock with Alexa, please check this manual.

If you tried everything and it still doesn't work, I would recommend you to contact Roborock official customer support:

I hope it will help you. Enjoy your life with the Roborock S5!

3 +2
Suggested Products

Comments ()

  1. SigTill
    04 september 2018, 13:40
    #      +1
    Even better — use the Flolevac to control the Xiaomi and download the newest firmware. Works like a charm!. play.google.com/store/apps/details?id=de.flole.xiaomi&hl=en
    reply   
    1. mobilus
      27 november 2018, 07:12
      #      0
      the same problem. who can fix it??
      reply   
      1. Robocock
        01 december 2018, 04:24
        #      0
        Just spent 3 hours attempting all possible fixes and nothing!
        I believe the region switch hack is a Chinese prank and this article is a troll

        Using iOS Mi Home and Roborock S50

        reply   
        1. Robocock
          03 december 2018, 12:16(edited})
          #      +3
          Fixed it!!! Again this is for Roborock S501-01, BC Model

          I got the following response from customer service as I attempted to return the unit: (Note: I am fixing some of the grammar for your benefit)

          1.Please go to app's setting to change region to your local region, do not select China mainland.
          (in my case I changed to US (Recommended), not the US (Singapore))
          2.If your phone is android, please go to phone's setting to enable the location permission.
          3. If your wifi password contains special characters like questions mark, colon, please change password without them to have a try.
          (this is what fixed it for me)
          4.If it says it could not connect public wifi, it is probably because your wifi's encryption mode is WEP. Please log in your router's page to change the encryption mode to WPA or WPA2.
          5.You could try to reset wifi by holding recharge button and spot cleaning button for 5 seconds until you hear voice reset wifi.
          6. Please notice the vacuum could not connect 5G HZ wifi.

          Notice: Please keep your eye on wifi indicator light under the cover of device. It will flash with higher frequency than normal status when it is trying to connect wifi and become solid when it is connected. Sometimes app may show error after connecting steps finish, but the wifi indicator light becomes solid and device is actually connected to wifi successfully. In this situation, please close the app and run it again to see if device is on the list of app.
          reply   
          1. Michael
            03 december 2018, 12:51
            #      0
            Hi,
            thank you so much for your solution! I've updated the article. Hope it will help other users as well.
            reply   
            1. essess
              14 march 2019, 08:02
              #      0
              Regarding «Please notice the vacuum could not connect 5G HZ wifi» does that mean that Mesh Wifi networks not separating the 2.4 and 5 GHz, like Google Wifi and TP-Link Deco M9 Plus, cannot connect to Roborock?
              reply   
            2. Richie
              06 march 2019, 02:12
              #      0
              My roborock S50 2nd generation keeps going offline everytime after it finishes charging.
              Have to reset the wifi each time to get it connected to the app again. Very annoying.
              I have it for 2 months now
              reply   
              1. Michael Fisher
                09 march 2019, 01:29
                #      0
                Hi,
                Did you try to contact Roborock official support? Hope they have some advice on how to solve this problem.
                reply   
                1. Leo
                  16 march 2019, 22:05
                  #      0
                  The same f… problem :(
                  reply   
                  1. lupoalba
                    22 march 2019, 10:30
                    #      0
                    also my roborock going offline everytime after it finishes charging…

                    reply   
                  2. Vas
                    08 march 2019, 22:13
                    #      0
                    Hi
                    I am on 5ghz wifi with iPhone 8. And I changed region to US and I reset few times still no luck connecting. I need help and I am not IT savvy. Can anyone pls guide me?
                    reply   
                    1. Michael Fisher
                      09 march 2019, 01:23
                      #      0
                      Hi,
                      you should switch your router to the 2.4Ghz frequency band since the Roborock doesn't work on 5Ghz.
                      reply   
                    2. Volodymyr Shulga
                      16 march 2019, 06:31
                      #      0
                      Had the same issue. Option 4 helped me, I had to change Wi-Fi encryption mode from WEP to WPA2 for my Wi-Fi router. For this I also had to find IP address of my router, for Mac it could be done in following way — osxdaily.com/2011/10/05/find-router-ip-address-mac/.
                      By the way — I had not had any warning about not secured connection, just was not able to connect my iPhone 8 to vacuum.
                      reply   


                       

                      Latest Posts
                      Latest Comments
                      lupoalba 22 march 2019, 10:30
                      also my roborock going offline everytime after it finishes charging…
                      Terry Day 22 march 2019, 00:34
                      I've had nothing but problems with the S50, and they offer a 2 year warranty but you contact Roborock and they dont want ...
                      Muth Tudor 21 march 2019, 10:41
                      I don't know if it will worth the T6 for them either. Inevitable the new robot (if it is even a little better) will drop ...
                      Natalie Red 21 march 2019, 09:40
                      Agree that it is not worth to upgrade if you already have the Roborock S5. But for new customers, it can be a good alter ...
                      Muth Tudor 21 march 2019, 06:59
                      From what I see the 3rd generation (T6) brings not much to the table. They could have waited a while longer (1-2 years) ...
                      Muth Tudor 21 march 2019, 06:52
                      From what I see the 3rd generation (T6) brings not much to the table. They could have waited a while longer (1-2 years) ...
                      Michael Fisher 19 march 2019, 05:08
                      Hi Thomas, where did you buy the 360 S7 model? Thanks.
                      Thomas 19 march 2019, 04:57
                      Thanks, D. Transocks works, and with latest S7 model.
                      Thomas 19 march 2019, 04:57
                      Yes, another Android user checking in: Transocks VPN works better indeed. Suspect Hola VPN not enough bandwidth, too man ...
                      Leo 16 march 2019, 22:05
                      The same f… problem :(